
Photoshop 
UNIT IV 

Creating Frame Animations 

In Photoshop, you use the Timeline panel to create animation frames. Each frame 
represents a configuration of layers. 

You can also create animations using a timeline and keyframes. See Creating 
timeline animations. 

 
Illustration of an animation. The unicycle image is on its own layer; the position of 
the layer changes in each frame of the animation. 

Follow these steps to create frame-based animations in Photoshop. 

1. Open a new document. If they are not already visible, open 
the Timeline and Layers panels. Make sure the Timeline panel is in 
frame animation mode. In the middle of the Timeline panel, select the 
downpointing arrow to choose Create Frame Animation and then select 
the button next to the arrow. 

2. Add a layer or convert the background layer. Because a background layer 
cannot be animated, add a new layer or convert the background layer to a 
regular layer. 

3. Add content to your animation. If your animation includes several objects 
that are animated independently, or if you want to change the color of an 
object or completely change the content in a frame, create the objects on 

separate layers. 

4. Create a Frame animation. In the Timeline panel, select the down arrow 
to select Create Frame Animation. 
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5. Add a frame to the Timeline panel. 

6. Select an animation frame.  

7. Edit the layers for the selected frame.  

● Turn visibility on and off for different layers. 
● Change the position of objects or layers to make layer content move. 
● Change layer opacity to make content fade in or out. 
● Change the blending mode of layers. 
● Add a style to layers. 

Photoshop provides tools for keeping a layer's characteristics the same 
across frames.  

2. Add more frames and edit layers as needed. The number of frames you 
can create is limited only by the amount of system memory available to 
Photoshop. 

Generate new frames with intermediate changes between two 
existing frames in the panel using the Tween command. This is a quick 
way to make an object move across the screen or to fade in or out.  

3. Set frame delay and looping options. Assign a delay time to each 
frame and specify looping so that the animation runs once, a certain 
number of times, or continuously.  

4. Preview the animation. Use the controls in the Timeline panel to play the 
animation as you create it. Then use the Save For Web command to 
preview the animation in your web browser.  

5. Optimize the animation for efficient download. 

6. Save the animation using any of these steps.  

● Save as an animated GIF using the Save For Web command. 

● Save in Photoshop (PSD) format so you can do more work on the 
animation later. 

● Save as an image sequence, QuickTime movie, or as separate files.  

Add frames to an animation 

Adding frames is the first step in creating an animation. If you have an image 
open, the Timeline panel displays the image as the first frame in a new animation. 
Each frame you add starts as a duplicate of the preceding frame. You then make 
changes to the frame using the Layers panel. 

1. Make sure the Timeline panel is in frame animation mode. 

2. Click the Duplicate Selected Frames button . 
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Select animation frames 

Before you can work with a frame, you must select it as the current frame. The 
contents of the current frame appear in the document window. 

In the Timeline panel, the current frame is indicated by a narrow border (inside the 
shaded selection highlight) around the frame thumbnail. Selected frames are 
indicated by a shaded highlight around the frame thumbnails. 

Select one animation frame 
1. Do one of the following in the Timeline panel: 

 

Creating Timeline Animations 

To animate layer content in timeline mode, you set keyframes in the Timeline 
panel, as you move the current-time indicator to a different time/frame, and then 
modify the position, opacity, or style of the layer content. Photoshop automatically 
adds or modifies a series of frames between two existing frames—varying the 
layer properties (position, opacity, and styles) evenly between the new frames to 
create the appearance of movement or transformation. 

For example, if you want to fade out a layer, set the opacity of the layer in the 
starting frame to 100% and click the Opacity stopwatch for the layer. Then move 
the current-time indicator to the time/frame for the ending frame and set the 
opacity for the same layer to 0%. Photoshop automatically interpolates frames 
between the start and end frames, and the opacity of the layer is reduced evenly 
across the new frames. 

In addition to letting Photoshop interpolate frames in an animation, you can also 
create a hand-drawn frame-by-frame animation by painting on a blank video layer. 

1. Create a new document. 

Specify the size and background contents. Make sure the pixel aspect ratio and 
dimensions are appropriate for the output of your animation. The color mode 
should be RGB. Unless you have special reasons for making changes, leave the 
resolution at 72 pixels/inch, the bit depth at 8 bpc, and the pixel aspect ratio at 
square. 

Make sure the Timeline panel is open. If necessary, click the down pointing arrow 
in the middle of the panel, choose Create Video Timeline from the menu, and then, 
click the button to the left of the arrow. If the Timeline panel is in frame animation 
mode, click the Convert To Video Timeline icon in the lower-left corner of the 
panel. 

2. Specify the Set Timeline Frame Rate in the panel menu. 

Specify the duration and frame rate. See Specify timeline duration and frame rate. 

3. Add a layer. 

Background layers cannot be animated. If you want to animate content, either 
convert the background layer to a normal layer or add any of the following: 
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● A new layer for adding content. 

● A new video layer for adding video content. 

● A new blank video layer for cloning content to or creating hand-drawn animations. 

4. Add content to the layer. 

5. (Optional) Add a layer mask. 

A layer mask can be used to reveal a portion of the layer’s content. You can 
animate the layer mask to reveal different portions of the layer’s content over time. 
See Add layer masks. 

6. Move the current time indicator to the time or frame where you want to set 
the first keyframe. 

See Use keyframes to animate layer properties. 

7. Turn on keyframing for a layer property. 

Click the triangle next to the layer name. A down-pointing triangle displays the 
layer’s properties. Then, click the stopwatch to set the first keyframe for the layer 
property you want to animate. You can set keyframes for more than one layer 
property at a time. 

8. Move the current time indicator and change a layer property. 

Move the current-time indicator to the time or frame where the layer’s property 
changes. You can do one or more of the following: 

● Change the position of the layer to make layer content move. 

● Change layer opacity to make content fade in or out. 

● Change the position of a layer mask to reveal different parts of the layer. 

● Turn a layer mask on or off. 

For some types of animation, such as changing the color of an object, or 
completely changing the content in a frame, you need additional layers with the 
new content. 

Note:  

To animate shapes, you animate the vector mask rather than the shape layer, using 
the Time-Vary stopwatch for Vector Mask Position or Vector Mask Enable. 

9. Add additional layers with content and edit their layer properties as 
needed. 

10. Move or trim the layer duration bar to specify when a layer appears in an 
animation. 

See Set the timeline area to preview. 

11. Preview the animation. 

Use the controls in the Timeline panel to play the animation as you create it. Then 
preview the animation in your web browser. You can also preview the animation in 
the Save For Web dialog box. See Previewing video or timeline animations. 
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12. Save the animation. 

You can save the animation as an animated GIF using the Save for Web command, 
or as an image sequence or video using the Render Video command. You can also 
save it in PSD format, which can be imported into Adobe After Effects. 

 

Creating Images For Video 

Steps 

Download Article 

1.  

1 
Open Photoshop, then click File- Open file, click on the first image and Image 
Sequence box. 

https://www.wikihow.com/Make-a-Video-Using-Photoshop


2.  

2 
The Frame Rate box will appear, decide how many frames per second you 
would like. It will have options in a drop down box to select or you can have a 
custom number of your choosing, OK. 

3.  

3 
Once the first image appears go to File, Export. In the dialogue box, select the 
Location to save to. File options, select QuickTime Movie, Settings, Settings, 
Compression Type H.264, OK. Size, 1280 X 720 HD, check Preserve Ratio box, in 
the drop down select Letterbox, OK. Render. 



4.  

4 
Wait for a bit while the movie Exports. 

● If you do not like the "timing" you can open Window, Animation. This 
will open up the animation bar, the bottom right corner of the toolbar is a 
little "film strip". The small image in the toolbar has a little upside down 
triangle, click this and a list of times will appear, you can try out different 
time delays between frames. To check out the different times click back 
on the little "film strip" and you will be able to watch the video. 

● Or you can start over and re-render your video selecting a different 
number of frames per second. 

2.  

5 
Your film will automatically save to your selected location once it is finished 
exporting. 



3.  

6 
ENJOY AND SHARE! 
 

Saving and Exporting Video and Animations 

In Photoshop, you can save and export videos and animations in different formats. 
Here’s a step-by-step guide to exporting them properly: 

 

1. Exporting as a GIF (For Simple Animations) 

If you’ve created a frame animation (Timeline Panel → Create Frame Animation), 
export it as a GIF: 

Steps: 

1. Go to File > Export > Save for Web (Legacy)... 
2. In the Preset, choose GIF 128 Dithered for better quality. 
3. Set the Colors (256 for high quality). 
4. Check Looping Options (e.g., “Forever” for infinite loops). 
5. Click Save and choose the destination. 

2. Exporting as a Video (For Longer or Complex Animations) 

If you’ve used the Video Timeline: 

Steps: 

1. Go to File > Export > Render Video… 
2. In the Render Video window:  

o Name the file and choose the location. 
o Under Format, select H.264 (.mp4) (best for web and social media) 

or QuickTime (.mov). 
o Choose a preset (e.g., High Quality for best resolution). 



o Adjust frame rate (24, 30, or 60 FPS depending on your needs). 
o Set the size (match document size or scale down if needed). 

3. Click Render to export the video. 

3. Exporting as an Image Sequence 

If you need individual frames (useful for further editing in another program): 

Steps: 

1. Go to File > Export > Render Video… 
2. Under Format, choose Image Sequence. 
3. Select PNG, JPEG, or TIFF. 
4. Choose a destination folder. 

Click Render. E 

 

Editing Video and Animation Layers 

Editing video and animation layers in Adobe Photoshop is a powerful way to 
create motion graphics, GIFs, and simple animations. Here’s a breakdown of how 
to work with video and animation layers in Photoshop: 

1. Open or Create a Video/Animation File 

● Import a video: Go to File > Open and select a video file, or use File > 
Import > Video Frames to Layers. 

● Create an animation from scratch: Open Window > Timeline and select 
Create Frame Animation or Create Video Timeline. 

2. Understanding the Timeline Panel 
● Frame Animation Mode (Good for GIFs, stop-motion effects) 

o Displays frames as individual images. 
o You can adjust the duration of each frame and create smooth 

transitions. 
● Video Timeline Mode (Good for video editing, motion effects) 

o Works like video editing software with layers as clips. 
o You can add keyframes for motion effects. 

3. Editing Video and Animation Layers 
Basic Editing: 

● Trim Clips: Drag the edges of video layers in the timeline to shorten them. 
● Rearrange Layers: Move layers up/down in the Layers panel to change 

visibility. 
● Cut Video: Use the Split at Playhead tool to divide clips. 



Adding Effects and Adjustments: 

● Apply Filters (Filter > Convert for Smart Filters) to non-destructively 
edit video layers. 

● Use Adjustment Layers (like brightness, contrast, color balance) to 
enhance video. 

● Use the Transform tool (Ctrl+T / Cmd+T) to resize or rotate elements. 

Animating with Keyframes: 

● Expand a video layer in the Timeline and click the Stopwatch icon next to 
Position, Opacity, or Style. 

● Move the playhead and adjust the property to create smooth transitions. 

Adding Text and Graphics: 

● Create a new layer for text or graphics. 
● Set its duration by dragging its edges in the Timeline. 
● Use keyframes to animate movement, opacity, or effects. 

4. Exporting the Animation/Video 

● For GIFs: Go to File > Export > Save for Web (Legacy) and select GIF 
format. 

● For MP4 Video: Go to File > Export > Render Video, choose H.264 
(MP4), set quality, and render. 

 
Bottom of Form 
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